Ben Karciauskas

This user hasn't shared any biographical information

Arrays with duplicate ID’s received by SRA

Problem –

Ran into this issue when configuring the HDS SRA 2.0 for SRM using a ouple of ASM2300 arrays. Everything installed ( SRM, VCenter, SRA, HDS CCI etc) and a HORCM instance was set up on each server as required. When trying to configure the SRA I keep getting this error –

“Arrays with duplicate ID’s received by SRA”.

Solution –

After digging through the error logs in c:\Documents and Settings\All Users\Application Data\ Vmware\Vmware vCenter Site Recovery Manager\Logs, I noticed that it was identifying the array on the first command LUN and then attempting to do it again at which point everything failed and I got the error message.

This ended up being be because the HORCM file was incorrectly configured. Under the HORCM_CMD section of the configuration file the I had the command LUNs listed one after the other like this –

#/************** For HORCM_CMD **************

HORCM_CMD

#dev_name                                       #dev_name

\\.\PHYSICALDRIVE1

\\.\PHYSICALDRIVE2

This caused the SRA to scan the fist device and return the array ID it then went to the second device which reported the same array ID and cause all my issues. The correct way of doing it is to add your command devices on a single line like this –

#/************* For HORCM_CMD ***************

HORCM_CMD

#dev_name                                       #dev_name

\\.\PHYSICALDRIVE1                       \\.\PHYSICALDRIVE2

Once I made the change and restarted the HORCMINST service I was able to detect the Array and all paired LUNs. Happy Days!

Advertisements

Leave a comment

Arrays with duplicate ID’s received by SRA

Problem –

Ran into this issue when configuring the HDS SRA 2.0 for SRM using a couple of ASM2300 arrays. Everything was installed ( SRM, VCenter, SRA, HDS CCI etc) and a HORCM instance was set up on each server as required. When trying to configure the SRA I keep getting this error –

“Arrays with duplicate ID’s received by SRA”.

Solution –

After digging through the error logs in c:\Documents and Settings\All Users\Application Data\ Vmware\Vmware vCenter Site Recovery Manager\Logs, I noticed that it was identifying the array on the first command LUN and then attempting to do it again at which point everything failed and I got the error message.

This ended up being be because the HORCM file was incorrectly configured. Under the HORCM_CMD section my HORCM0.conf file the I had the command LUNs listed one after the other like this –

#/****************** For HORCM_CMD ****************************

HORCM_CMD

#dev_name                                       #dev_name                                       #dev_name

\\.\PHYSICALDRIVE1

\\.\PHYSICALDRIVE2

This caused the SRA to scan the fist device and return the array ID it then went to the second device which reported the same array ID and cause all my issues. The correct way of doing it is to add your command devices on a single line like this –

#/****************** For HORCM_CMD ****************************

HORCM_CMD

#dev_name                                       #dev_name                                       #dev_name

\\.\PHYSICALDRIVE1                       \\.\PHYSICALDRIVE2

Once I made the change and restarted the HORCMINST service I was able to detect the Array and all paired LUNs. Happy Days!

1 Comment

Microsoft changes VDI Windows Licensing

Just a quick note about the new Microsoft desktop licensing for virtual desktops that I blatantly copied from here but wanted to post so I would remember.

  • PCs covered under SA will no longer need a separate VECD license, instead this usage right will be included in SA thus eliminating the separate $23 per device fee.
  • PCs not covered under SA, thin clients or other clients that cannot run a full Windows OS, customers can purchase VDA for $100 per device/year, a $10 decrease from the previous VECD license price.
  • Roaming use rights allows users to be able to access their virtual desktops from secondary devices like home PCS, kiosks and internet cafes without additional licensing costs.

Leave a comment

Installing vCenter on Server 2008 R2

There are a couple of small gotchas to be aware of when installing vCenter on a Windows 2008 R2. The main reason for this is that R2 is 64-bit only. The issues arn’t with the installation of vCenter as much as issues with getting the installation to recognise the connection to the SQL backend server.

vCenter requires a 32-bit DSN. The problem on R2 is that if you setup a DSN through Start > Administrative Tools > Data Sources (ODBC) the vSphere installer won’t be able to see it as the created DSN will be a 64-bit connection.

In addition to a 32-bit DSN vCenter also requires the SQL (2005 or 2008) native client. The confusing part is you need to download and install the 64x version of the native client and then use the procedure below to setup the connection.

So here is a quick guide on installing vCenter 4.0 on a Windows 2008 R2 server.

Prerequisites –

Procedure –

  1. Download the native client from the above link
  2. Install the SQL 2008 native client with default settings
  3. From the run command – %systemdrive%\Windows\SysWoW64\Odbcad32.exe
  4. Select the System DSN Tab
  5. Choose the Native SQL Client
  6. Run through the rest of the setup of the DSN connection as normal.
  7. Run the vCenter installation as normal and the installation program should show you DSN as a Database connection option.

Note – If you go back to Start > Administrative Tools > Data Sources (ODBC) no  DSN’s will appear. This is normal as they have been created using the 32-bit tool and so will only show up when you launch it from %systemdrive%\Windows\SysWoW64\Odbcad32.exe

Leave a comment

How to install the HP CIM providers on ESXi

Quick guide on installing the HP ESXi CIM providers

Prerequisites

Procedure

Note – Bold text should be replace with relevant information.

  1. Copy bundle to c:\temp
  2. Place the target host in maintenance mode
  3. Open the vsphere CLI command line
  4. Change to bin directory by typing CD bin
  5. Run vihostupdate.pl –server ESXiHOST –install –bundle c:/temp/bundle.zip
  6. Reboot the host
  7. Check it installation – Run vihostupdate.pl –server ESXiHOST –query

You should now have additional information on hardware status in the vSphere hardware status tab.

Leave a comment

One Liners

Just a quick not e mention a helpful little site I discovered today.

It’s called Ready Lines and it provides a useful reference for one line commands for all sorts of CLI’s including cisco.

Leave a comment

Error during the configuration of the host: Cannot open volume: /vmfs/volumes/

I came across this error after setting up and FlexVolume on a Netapp filer and trying to connect to it from vSphere ESX host.

I had run through the wizard and made sure that each of the ESX hosts had read/write access as well as “Root” access to the export/volume but I continued to get this error:

“Error during the configuration of the host: Cannot open volume: /vmfs/volumes/270c64e8-cae0114b”

Originally I thought it may be that I had underscores in my export name as described in the Vmware KB article. I changed the export name to something without an underscore but still no dice.

It turns out even if you specify Unix security when creating the export, the Netapp filer will create it using NTFS by default! Why it sets the underlying security to NTFS on a NFS export with Unix security is beyond me. It may be the version of OnTap on our old dev filer (7.2.6.1)

To change this you need to do the following:

  1. Logon to your filer web management interface
  2. Expand “Volumes”
  3. Expand “Qtrees”
  4. Click “Manage”
  5. Click on the “NTFS” link next to the export you need to change
  6. Change the security style to “Unix” and then apply
  7. Go back to your host and try adding the NFS volume

I recommended getting familiar with this Netapp and vSphere best practices document as well.

9 Comments